Square webhooks delayed

Incident Report for Thrive

Update

We're continuing to investigate an unusually high volume of traffic from the Square integration, which is the root cause of the delays. If you have a Square integration connected, you'll continue to experience significant delays in transaction updates. We'll share another update as soon as we have more information or a fix in place.
Posted Jul 24, 2026 - 16:21 MDT

Investigating

We are currently investigating an issue with Square webhooks causing system instability. Expect Square transactions to be significantly delayed while we investigate root cause.
Posted Jul 24, 2026 - 12:12 MDT
This incident affects: thrivemetrics.com (Thrive Metrics Application, Thrive Catalog Management) and shopventory.com (Shopventory Application).