This incident is now resolved for all integrations outside of Square. Queue processing has returned to normal, pre-incident rate. Square integrations remain affected and continue to be tracked in a separate, ongoing incident.
Posted Jul 24, 2026 - 19:08 MDT
Monitoring
Outside of Square integrations, most connected integrations should ramp back up to normal sync speeds over the next few hours. Square integrations continue to be affected separately and are being tracked in a dedicated incident. We'll continue monitoring and will confirm once things are fully back to normal.
Posted Jul 24, 2026 - 16:37 MDT
Identified
We're currently experiencing a delay in how quickly data updates between Thrive and your connected integration partners. This means changes made in one system (like inventory counts, orders, or product updates) may take longer than usual to show up in the other. Your data is queued up and will sync automatically once processing catches up.
Posted Jul 24, 2026 - 13:56 MDT
This incident affected: thrivemetrics.com (Thrive Metrics Application, Thrive Catalog Management), shopventory.com (Shopventory Application), and Shopify API & Mobile.